apache2 @ apache2-default

Hier darf alles rein, was mit dem Betriebssystem an sich zu tun hat. Generelle Probleme, Tipps oder Tricks zu Linux, Libraries, Compilern, Konfigurationen, etc :-)
Antworten
BoEhSeR-OnKeL
IRC-Addict
Beiträge:74
Registriert:27. Mär 2005, 17:19
Wohnort:Oberhausen (NRW)
Kontaktdaten:
apache2 @ apache2-default

Beitrag von BoEhSeR-OnKeL » 2. Apr 2008, 00:56

hallo, habe mir grad mein neuen root eingerichtet. aber diesmal zum ersten mal selber apache2 installed.
soweit so gut, schein zu laufen, doch jedesmal wen ich die IP vom server im browser eigebe erscheint am ende der url immer "http://85.xxx.xxx.xxx/apache2-default/" wo bzw wie kann ich es einstellen das er direkt die index.html ( oder eben index.php am besten wär wen er es automatscih checkt was da liegt ) aus var/www/ aufruft? und nich die aus var/www/apache2-default/ ??

im verzeichnis /etc/apache2/sites-available/default is als "DocumentRoot" /var/www angegeben. :idea:

Code: Alles auswählen

h1382015:~# grep -r "DocumentRoot" /etc/apache2/
/etc/apache2/sites-enabled/000-default:DocumentRoot /var/www
/etc/apache2/sites-available/default:DocumentRoot /var/www
Operating system: Debian Linux 4.0

mfg
Wer keine angst vorm Teufel hat, Braucht auch keinen Gott.

BoEhSeR-OnKeL
IRC-Addict
Beiträge:74
Registriert:27. Mär 2005, 17:19
Wohnort:Oberhausen (NRW)
Kontaktdaten:

Beitrag von BoEhSeR-OnKeL » 3. Apr 2008, 00:24

habs dan doch mit hilfe eines anderen hinbekommen

für die, die das gleiche problem haben hier die lösung....

die datei 000-default im verzeichnis /etc/apache2/sites-enabled/ ist dafür zuständig.

einfach: nano /etc/apache2/sites-enabled/000-default

und die zeile: RedirectMatch ^/$ /apache2-default/

löschen, speichern und dan einmal "/etc/init.d/apache2 force-reload" und schon is die sache gegessen :D
Wer keine angst vorm Teufel hat, Braucht auch keinen Gott.

Antworten