falscher Ident

Hier findest du jede Art von Hilfestellung zum Thema Installation, Konfiguration und Betrieb von Eggdrop-Bots
Antworten
Devilish
Newbie
Beiträge:22
Registriert:26. Jun 2005, 16:01
falscher Ident

Beitrag von Devilish » 30. Aug 2006, 19:56

Hi,

habe einen neuen Root-Server und wollte meine BNCs und Eggdrop installieren. Geht auch alles, außer das der Eggdrop einen falschen ident nimmt.

Erst hat er den genommen, mit dem ich ihn auf dem Root-Server gestartet haben und jetzt einen Ident vom BNC.

Was habe ich denn falsch gemacht?

Danke für Eure Hilfe schonmal.

Crusher
Newbie
Beiträge:18
Registriert:10. Aug 2006, 16:06

Beitrag von Crusher » 30. Aug 2006, 21:11

zeisch doch aml deine oidentd.conf ^^

Devilish
Newbie
Beiträge:22
Registriert:26. Jun 2005, 16:01

Beitrag von Devilish » 3. Sep 2006, 15:03

Das ist meine conf.

Code: Alles auswählen

default {
        default {
                deny spoof
                deny spoof_all
                deny spoof_privport
                allow random_numeric
                allow numeric
                allow hide
        }
}
user root {
        default {
                force reply "UNKNOWN"
        }
}


user noob {
        default {
                allow spoof
                allow spoof_all
                allow random
                allow hide
        }
}

Devilish
Newbie
Beiträge:22
Registriert:26. Jun 2005, 16:01

Beitrag von Devilish » 3. Sep 2006, 16:59

habe das Problem gelöst. Hatte einen falschen Pfad beim eggdrop angegeben.

Devilish
Newbie
Beiträge:22
Registriert:26. Jun 2005, 16:01

Beitrag von Devilish » 13. Sep 2006, 17:19

Musste meinen Server neustarten und jetzt stehe ich wieder vor einem ähnlichen Termin.

Für jeden BNC bekomme ich den gleichen Ident angezeigt und zwar den Benutzer mit dem ich den BNC gestartet habe.

Kann mir jemand helfen?

Hendrik
Chef
Beiträge:2076
Registriert:2. Sep 2003, 16:43
Wohnort:Berlin
Kontaktdaten:

Beitrag von Hendrik » 13. Sep 2006, 17:34

Hi,

läuft oidentd? /etc/oidentd.conf mit dem richtigen Benutzernamen versehen? existiert ~benutzername/.oidentd.conf mit dem korrekten Inhalt (gewünschter Ident des bots?)

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

Devilish
Newbie
Beiträge:22
Registriert:26. Jun 2005, 16:01

Beitrag von Devilish » 13. Sep 2006, 18:25

Ja lief alles.

Haben den BNC neu konfiguriert und jetzt geht es.

Was mit dem Ident von Bot ist, weiß ich nicht. Der läuft noch unter dem falschen Ident.

Hendrik
Chef
Beiträge:2076
Registriert:2. Sep 2003, 16:43
Wohnort:Berlin
Kontaktdaten:

Beitrag von Hendrik » 13. Sep 2006, 19:44

oidentd.tcl (oder ähnliches script, siehe Forumssuche) eingebunden, damit der eggdrop mit dem oidentd, also der ~benutzername/.oidentd.conf, zusammenarbeitet?
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

Devilish
Newbie
Beiträge:22
Registriert:26. Jun 2005, 16:01

Beitrag von Devilish » 13. Sep 2006, 20:47

Habe das Script.
Habe mich mal getraut den Bot neuzustarten :) und er hat jetzt auch den richtigen Ident.

Antworten