Blinker-OIdentd, geht - geht nicht

Hilfestellungen zur Installation, Konfiguration und Inbetriebnahme eines Bouncers.. psybnc, bnc, muh, ezbounce, etc...
Antworten
PigPen
Beiträge:4
Registriert:22. Jun 2007, 23:26
Blinker-OIdentd, geht - geht nicht

Beitrag von PigPen » 23. Jun 2007, 00:00

Hallo zusammen,

ich bin gerade dabei auf neue Hardware umzuziehen und nächste Woche will ich als letzten Schritt die BNC's rüberziehen. Daher habe ich schon mal den Ident-Dämon oidentd installiert.

Der Server läuft unter SUSE 10.1
oidentd habe ich diesmal über yast installiert. (Die vorherigen 3 mal immer von Hand - da lief auch immer alles problemlos.)

Die oidentd.conf habe ich vom alten Server übernommen. (Ist übrigens genau die gleiche wie hier im Tutorial.)
oidentd wird über "rcoidentd start" gestartet, bzw. über "rcoidentd restart" neu gestartet.

Unter /etc/sysconfig gibt es eine oidentd Datei in der man OIDENTD_OPTIONS mitgeben kann. Hier habe ich "-C /etc/oidentd.conf -u nobody -g nobody" eingetragen.
Somit ergibt ein ps aux | grep oidentd folgende Ausgabe:

Code: Alles auswählen

nobody   11414  0.0  0.0   2000   380 ?        Ss   22:27   0:00 /usr/sbin/oidentd -C /etc/oidentd.conf -u nobody -g nobody
PsyBNC läuft noch nicht, aber diverse Gameserver welche eine Verbindung zum Quakenet herstellen (Reporterfunktion).

Mal sieht das dann in etwa so aus(richtig):
Join: (Reporter) (gameserveruser@domain.de)

und mal so (falsch):
Join: (Reporter) (~tost@domain.de)
(Die ident tost ist in der ini des gameservers eingetragen)

Bei jedem Mapwechsel wird die Verbindung neu aufgebaut und man weiss nie wie sich das Ding meldet. Daher bezweifle ich, das dies beim PsyBNC richtig funktionieren wird.

Bisher, bei den 3 vorherigen Installationen, hat mit der genutzten /etc/oidentd.conf dies immer auch bei den gameservern problemlos funktioniert.

Die Usernamen sind gleich geblieben.

Ich bezweifle eigentlich, daß etwas an meiner Konfiguration falsch ist.
  • 1. funktioniert es ja manchmal
  • 2. hat die selbe Konfiguration bisher immer funktioniert
Ich hab aber diesmal dann auch eine .oidentd.conf mit rw-r----- Rechten des jeweiligen Gameserveruser in sein entsprechendes Homelaufwerk ~Gameserveruser gelegt, nachdem dieses Problem aufgetaucht ist. Das hatte ich bislang nicht gebraucht. Aber auch das hat nicht geholfen.

Im Homelaufwerk des PsyBNC-Users war die .oidentd.conf natürlich bisher auch immer drin :)

Also wenn mir jemand erklären kann, warum oidentd mal zu funktionieren scheint und mal nicht, wäre ich sehr dankbar.
Vielleicht kann mir auch noch jemand was zur option -t (timeout wert) des oidentds sagen.

Gruß
PigPen


*** Update ***
Also wie befürchtet funktioniert das ganze auch mit dem psybnc nicht richtig. Bekomme auch hier manchmal die ~ .
Die .oidentd.conf konnte der psybnc jedoch bearbeiten!
Zuletzt geändert von PigPen am 22. Jul 2007, 17:31, insgesamt 4-mal geändert.

PigPen
Beiträge:4
Registriert:22. Jun 2007, 23:26

Beitrag von PigPen » 25. Jun 2007, 10:46

Hallo,

erst mal muss ich mich ganz herzlich bei Hendrik bedanken, mit dem ich mich über ICQ unterhalten habe. Das ist wirklich nicht selbstverständlich wie hilfsbereit Du bist Bild.

Ich habe das Problem nun endlich (scheinbar) gelöst, in dem ich die neuere Version 2.0.8 von http://ojnk.sourceforge.net/ installiert habe.
Ich hatte bisher immer - wie auch in diesem Tutorial beschrieben - die Version 2.0.7 eingesetzt.
Aus dem Changelog wird zwar nicht ersichtlich, welche Änderung mich betrifft, aber vllt. liegt es daran das ich zum ersten mal oidentd auf einem Dualcore 64bit Prozessor betreibe.


***Update***
Zu früh gefreut. Es funktioniert zwar häufiger, aber nicht immer. Im System-Log steht übrigens immer Successful

Code: Alles auswählen

oidentd[9232]: [clanserver4u.de.quakenet.org] Successful lookup: 56186 , 6667 : psybnc (PigPen)
Wobei genau dieser Eintrag im IRC mit ~ erschien.

Erfolgreich hingegen war folgender Eintrag:

Code: Alles auswählen

oidentd[9180]: [83.140.172.212] Successful lookup: 7784 , 6667 : psybnc (PigPen)
Ob das was mit der Zahl 56186 zu tun hat? Vielleicht kann oidentd keine Anfragen > 32000 richtig behandeln?

*** Update 2 ***
Auch dies scheint nicht der Fall zu sein:

Code: Alles auswählen

oidentd[9290]: Connection from clanserver4u.de.quakenet.org (194.124.229.59):52234
oidentd[9290]: [clanserver4u.de.quakenet.org] Successful lookup: 56835 , 6667 : psybnc (PigPen)
War auch wirklich erfolgreich!



Gruß
PigPen

PigPen
Beiträge:4
Registriert:22. Jun 2007, 23:26

Beitrag von PigPen » 30. Jun 2007, 17:15

So, nun läuft oidentd richtig.

Ich habe die Option --reply=irgendwas hinzugefügt. Vorher hatte ich schon mit -r=irgendwas probiert, jedoch ohne Erfolg.

Irgendwo hier im Forum bin ich auf eine ähnliche Lösung bei Debian gestossen.

PigPen
Beiträge:4
Registriert:22. Jun 2007, 23:26

Beitrag von PigPen » 22. Jul 2007, 17:34

Jetzt fängt die Sache wieder an:

Code: Alles auswählen

Jul 22 17:08:04 s12345678 oidentd[4379]: Connection from irc.multiplay.co.uk (85.236.110.226):64289
Jul 22 17:08:04 s12345678 oidentd[4379]: [irc.multiplay.co.uk] Failed lookup: 7784 , 6667 : (returned irgendwas)
Jul 22 17:08:21 s12345678 oidentd[4382]: Connection from mediatraffic.fi.quakenet.org (195.12.59.195):65209
Jul 22 17:08:21 s12345678 oidentd[4382]: [mediatraffic.fi.quakenet.org] Successful lookup: 7784 , 6667 : username (username)

Antworten