znc-0.047

Hilfestellungen zur Installation, Konfiguration und Inbetriebnahme eines Bouncers.. psybnc, bnc, muh, ezbounce, etc...
FreeSlider
Schon länger da
Beiträge:36
Registriert:27. Mär 2006, 22:05
Wohnort:Visselhövede
Kontaktdaten:
znc-0.047

Beitrag von FreeSlider » 22. Okt 2007, 19:31

Hallo leute,

hat jemand erfahrung mit dem znc-0.047, ich habe zur zeit age probleme mit der insteralltation von dem bnc.
[ ** ]
[ ** ] To connect to this znc you need to connect to it as your irc server
[ ** ] using the port that you supplied. You have to supply your login info
[ ** ] as the irc server password like so.. user:pass.
[ ** ]
[ ** ] Try something like this in your IRC client...
[ ** ] /server <znc_server_ip> xxxxxx FreeSlider:<pass>
[ ** ]
[ ?? ] Launch znc now? (yes/no) [yes]: yes
[ ] Opening Config [/srv/www/htdocs/web4/.znc/configs/znc.conf]... [ No such
[ !! ]
[ ** ] Restart znc with the --makeconf option if you wish to create this config.
[ ** ] Unrecoverable config error.
web4@xxx:~/files/znc-0.047> ./znc -d=/srv/www/htdocs/web4/files/znc
[ ] Opening Config [=/srv/www/htdocs/web4/files/znc/configs/znc.conf]... [ No
[ !! ]file ]
[ ** ] Restart znc with the --makeconf option if you wish to create this config.
[ ** ] Unrecoverable config error.
web4@xxx:~/files/znc-0.047> ./znc -d=/srv/www/htdocs/web4/files/znc/znc.conf
[ ] Opening Config [=/srv/www/htdocs/web4/files/znc/znc.conf/configs/znc.conf
[ !! ] Not a file ]
[ ** ] Unrecoverable config error.

web4@xxx:~/files/znc-0.047>
hier mal ein auszug, vielleicht hilft es euch ja. Danke euch schon

Hendrik
Chef
Beiträge:2076
Registriert:2. Sep 2003, 16:43
Wohnort:Berlin
Kontaktdaten:

Beitrag von Hendrik » 22. Okt 2007, 20:31

Hallo,

ich habe zwar znc noch niemals verwendet und habe auch keine Ahnung wie dessen Aufbau/Konfiguration/Installation/... abläuft. Was ich aber deutlich lesen kann sind die folgenden Fehlermeldungen:

Code: Alles auswählen

[ ] Opening Config [/srv/www/htdocs/web4/.znc/configs/znc.conf]... [ No such [es fehlt wohl "file or directory"]
oder ...

Code: Alles auswählen

[ ** ] Restart znc with the --makeconf option if you wish to create this config. 
Scheint so, als gäbe es da noch keine Konfigurationsdatei. Zumindest kann er da nichts finden. Hast du das Ding mal mit --makeconf als Parameter gestartet, damit da sowas angelegt wird?

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

FreeSlider
Schon länger da
Beiträge:36
Registriert:27. Mär 2006, 22:05
Wohnort:Visselhövede
Kontaktdaten:

Beitrag von FreeSlider » 22. Okt 2007, 20:34

Code: Alles auswählen

[ ** ] Restart znc with the --makeconf option if you wish to create this config.
wenn ich das ausführe legt auch ne znc.conf an, nur kann ich diese nicht starten, weil er es über den befehl nicht aufruft

Code: Alles auswählen

./znc
irgendwo liegt das problem drinn, das er diese conf nicht wieder findet. da er immer wieder von ausgeht das sie in

Code: Alles auswählen

/srv/www/htdocs/web4/.znc
liegen soll :(

Hendrik
Chef
Beiträge:2076
Registriert:2. Sep 2003, 16:43
Wohnort:Berlin
Kontaktdaten:

Beitrag von Hendrik » 24. Okt 2007, 20:45

*idee* hast du unter umständen beim installieren des znc "make install" vergessen? weil der anscheinend vermutet, dass er sich "im normalfall" in einem anderen verzeichnis befindet...?!

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

FreeSlider
Schon länger da
Beiträge:36
Registriert:27. Mär 2006, 22:05
Wohnort:Visselhövede
Kontaktdaten:

Beitrag von FreeSlider » 24. Okt 2007, 22:58

Code: Alles auswählen

web4@xxxx:~/files/znc-0.047> make install
make[1]: Entering directory `/srv/www/htdocs/web4/files/znc-0.047/modules'
make[1]: Für das Ziel »all« ist nichts zu tun.
make[1]: Leaving directory `/srv/www/htdocs/web4/files/znc-0.047/modules'
mkdir -p /srv/www/htdocs/web4/files/znc/bin
mkdir -p /srv/www/htdocs/web4/files/znc/include/znc
install -m 0755 znc /srv/www/htdocs/web4/files/znc/bin
install -m 0755 znc-config /srv/www/htdocs/web4/files/znc/bin
install -m 0755 znc-buildmod /srv/www/htdocs/web4/files/znc/bin
install -m 0644 *.h /srv/www/htdocs/web4/files/znc/include/znc
if test -n "modules"; then (cd modules; make install DESTDIR=); fi
make[1]: Entering directory `/srv/www/htdocs/web4/files/znc-0.047/modules'
mkdir -p /srv/www/htdocs/web4/files/znc/libexec/znc
rm -rf /srv/www/htdocs/web4/files/znc/libexec/znc/*.so
for a in *; do \
        if [ -d $a ] && [ -f ${a}.so ]; then \
                cp -Rp $a /srv/www/htdocs/web4/files/znc/libexec/znc; \
        fi \
done
install -m 0755 autoattach.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 autoop.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 away.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 awaynick.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 chansaver.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 crypt.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 email.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 imapauth.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 modperl.so /srv/www/htdocs/web4/files/znc/libexec/znc
for i in *.pm; do \
        install -m 0755 $i /srv/www/htdocs/web4/files/znc/libexec/znc; \
done
install -m 0755 partyline.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 perform.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 raw.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 sample.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 savebuff.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 schat.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 shell.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 stickychan.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 watch.so /srv/www/htdocs/web4/files/znc/libexec/znc
install -m 0755 webadmin.so /srv/www/htdocs/web4/files/znc/libexec/znc
make[1]: Leaving directory `/srv/www/htdocs/web4/files/znc-0.047/modules'
web4@xxxx:~/files/znc-0.047> ./znc
[    ] Opening Config [/srv/www/htdocs/web4/.znc/configs/znc.conf]... [ No such [ !! ]
[ ** ] Restart znc with the --makeconf option if you wish to create this config.
[ ** ] Unrecoverable config error.
web4@xxxx:~/files/znc-0.047>
habe den make install noch mal ausgeführt, da ich mir nicht sicher war, aber dort geht er in die richtigen ornder, und wenn ich dann den ./znc wieder ausführe, bekomme ich identischen fehler. Ich bin solangsam mit meinem lataein für die installation am ende :(

Benutzeravatar
Weble
3l33t
Beiträge:111
Registriert:2. Apr 2005, 23:09
Wohnort:Nürnberg
Kontaktdaten:

Beitrag von Weble » 19. Dez 2007, 14:57

hoi

is auch schon lange her der thread, aber mich würds interessieren ob dus geschaffft hast den znc zu installieren ?

Wie man dem wiki entnehmen kann, hatte ich mal vor auch für den ne Install anleitung zu schreiben, jedoch bin ich nie dazu gekommen genauso wenig zur konfiguration vom ezbounce oder wie der heißt *g*

Hab demnächst urlaub, sollte ihc da mal zeit finden werd ich das nachholen :)


Mfg
Weble

FreeSlider
Schon länger da
Beiträge:36
Registriert:27. Mär 2006, 22:05
Wohnort:Visselhövede
Kontaktdaten:

Beitrag von FreeSlider » 12. Jan 2008, 12:46

moin Weble,

ja ich habe es dann doch noch hin bekommen, nach dem ich immer wieder mal rum probiert habe. Dadurch das ich für jede anwendung ein confixxuser anlege war es problematisch.

Ich weiß nicht warum ich auf die Idee gekommen bin. Aber habe irgendwann dem confixxuser sein Home verzeichniss die 777 gegeben. Da besitzer des Ordners root ist. Dannach konnte der znc die ordner die erbrauchte auch auf der ebene anlegen. Aber erst mal auf die Idee kommen, das war das schwere. Aber nun läuft der znc, und ich bin glücklich.

Hendrik
Chef
Beiträge:2076
Registriert:2. Sep 2003, 16:43
Wohnort:Berlin
Kontaktdaten:

Beitrag von Hendrik » 12. Jan 2008, 16:15

Das 777 aber sicherheitstechnisch ziemlich ungünstig ist - ist dir bewusst, oder? das nimmst du dann in kauf?

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

FreeSlider
Schon länger da
Beiträge:36
Registriert:27. Mär 2006, 22:05
Wohnort:Visselhövede
Kontaktdaten:

Beitrag von FreeSlider » 12. Jan 2008, 18:13

Habe es nach der insterlation ja wieder zurück geschaltet, aber zu dem moment war es zweckmäßig, anderes wollte er nicht

Benutzeravatar
Weble
3l33t
Beiträge:111
Registriert:2. Apr 2005, 23:09
Wohnort:Nürnberg
Kontaktdaten:

Beitrag von Weble » 13. Jan 2008, 13:15

Und wie sind so die eindrücke vom znc ?

Also was gefällt dir so an dem, und was nicht :)

ich installier den etz dann gleich mal :)

FreeSlider
Schon länger da
Beiträge:36
Registriert:27. Mär 2006, 22:05
Wohnort:Visselhövede
Kontaktdaten:

Beitrag von FreeSlider » 13. Jan 2008, 23:17

Mir gefällt der znc eigentlich super, habe eigenltihc nichts was mir dort nicth gefällt

was eine superfunktion ist, das er auch wirklich im channel mit logt, sprich wenn man mal wirklich ein paar stunden offline ist, kann man dennoch nachvollziehen, was so geschrieben worden ist, und man bekommt halt auch mit wenn man im channel gerufen worden ist. Finde diese funktion einfach spitze.

Weitere gute sache, das gleich standartmäßig das webinterface mit bei ist, und es nicht noch zusätzlich installieren muss.

Im groben und ganzen, einfach nur super

Benutzeravatar
Weble
3l33t
Beiträge:111
Registriert:2. Apr 2005, 23:09
Wohnort:Nürnberg
Kontaktdaten:

Beitrag von Weble » 14. Jan 2008, 10:39

Ich bin jetzt gestern leider nicht mehr dazu gekommen den znc zu installieren, bekomm aber heute hier in nbg internet, dann werd ich das heute mal nachholen :)

Benutzeravatar
Weble
3l33t
Beiträge:111
Registriert:2. Apr 2005, 23:09
Wohnort:Nürnberg
Kontaktdaten:

Beitrag von Weble » 16. Jan 2008, 09:43

Also der znc rennt nun bei mir :)

Nur allerdings war ich noch mit ihm verbunden *g* und das Webinterface macht auch noch ein paar Probleme, was ich negativ find ist, dass das Webinterface auf port 8080 läuft und das ganze hardgecodet ist. Ohne Änderung am Quelltext lässt sich das leider nicht ändern.

Ich hab mir den jetzt mal geändert, aber kann mich nicht einloggn, nach eingabe der Login Daten wartet er etwa 30 sek. und bringt mir ernaut das Login. Und auf Port 8080 kann ich ihn unmöglich so einfach laufen lassen *g*
evtl. werd ich mir ne kleine VM mal lokal anlegen und da testen :)

FreeSlider
Schon länger da
Beiträge:36
Registriert:27. Mär 2006, 22:05
Wohnort:Visselhövede
Kontaktdaten:

Beitrag von FreeSlider » 16. Jan 2008, 14:55

Stop!!!

du brauchst nichts zusätzlich installieren, gehe einfach in die conf datei und schreib mit einem leerschrit hinter dem webinterface den port den du gerne haben möchtest. wenn das gemacht hast, startetst du einfach den znc neu und dann kommst du nur noch über den port aufs webinterface.

Genauso kannst du es auch änderen wenn du übern client eine andere ip verwenden möchtet, es ist sogar ein ssl verbindung von client zum bnc möglich. Was glabue bei den anderen versionen nicht möglich war, oder ich habe es nicht gefunden gehabt ;-)

Benutzeravatar
Weble
3l33t
Beiträge:111
Registriert:2. Apr 2005, 23:09
Wohnort:Nürnberg
Kontaktdaten:

Beitrag von Weble » 16. Jan 2008, 16:49

Okey suppa ^^

hab dennoch probleme beim einloggen weder mit xchat noch mit dem webinterface funktioniert das

Dabei sind ident und passwort richtig gesetzt (PW hab ich anhand der md5 summe in der config überprüft)

Ich suche derzeit eine log datei für den znc gibts sowas irgendwo? :)

*edit*
ach ja meldung "Falsches PAsswort" *g*

Gesperrt