nochmal ein Problem mit oidentd

Hilfestellungen zur Installation, Konfiguration und Inbetriebnahme eines Bouncers.. psybnc, bnc, muh, ezbounce, etc...
t0m

nochmal ein Problem mit oidentd

Beitrag von t0m » 10. Nov 2004, 17:06

Hallo,

ich bin nun bei weitem mehr keiner von den Anfängern und habe nun folgendes Problem:
IDENT = PSYBNCPROZESSUSER

Also auf gut deutsch: Ich habe immer den User als Ident, unter dem ich den Psybnc gestartet habe.

Für mich würde das nun auf irgendwelche nicht vorhandenen Leseberechtigungen hindeuten, was ich natürlich auch getestet habe.

OIdentd gestartet als user nobody group nogroup - psybnc gestartet unter user bnc (group ist users) -> oidentd.conf folgende user und groups getestet: nobody:nogroup nobody:users bnc:users bnc:nogroup
Alles kein Erfolg. (Ja ich hab Oidentd danach neu gestartet)

Danach hab ich Oidentd unter der selben gruppe und dem selben user wie den psybnc Prozess gestartet. Aber auch das brachte mich ned weiter.

Zum Schluss meines Tests hab ich Oidentd sogar mit root gestartet. Aber auch da keine Lösung.

Was mach ich nun?

Hier noch meine Configs:
oidentd.conf
default {
default {
deny spoof
deny spoof_all
deny spoof_privport
allow random_numeric
allow numeric
allow hide
}
}
user root {
default {
force reply "UNKNOWN"
}
}


user bnc {
default {
allow spoof
allow spoof_all
allow random
allow hide
}
}
config.h mit OIdentd Unterstützung
/*
* Configuration file for psyBNC, created by menuconf
*/

/* Encryption */

#define CRYPT

/* Encryption Type*/

#define BLOWFISH

/* Allow Translation */

#define TRANSLATE

/* Allow internal network */

#define INTNET

/* Allow traffic logging */

#define TRAFFICLOG

/* Allow linkage of bouncers */

#define LINKAGE

/* Allow the dcc File-Functions */

#define DCCFILES

/* Pipe dcc Chats */

#define DCCCHAT

/* Allow to add more users */

#define MULTIUSER

/* Number of max. Users */

#define MAXUSER 50

/* Number of max. Connections per User */

#define MAXCONN 99

/* Allow the usage of scripts */

#define SCRIPTING

/* Support oIdentd */

#define OIDENTD

/* Use blocking DNS */

#define BLOCKDNS

/* Allow multiple irc connections per user */

#define NETWORK

/* Allow Proxy Support */

#define PROXYS

/* The logging level */

#define LOGLEVEL 0

/* SSL-Security */

#define SSLSEC 2
Hoffe, das da jemand ne Lösung hat, weil ich bin am Ende mit meinem Latein.

Gruß
t0m

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 10. Nov 2004, 19:31

Hi,

erstmal ein bißchen die lage sondieren:

1. Was gibt dir ls -lah /home/bnc/.oidentd.conf ? (mich interessieren vor allem die user:group und die chmodes..)
2. ps aux | grep oidentd (ich weiß, du hast es schon genannt, aber der fehlerkontrolle und besseren übersicht bitte schlicht und einfach nochmal posten)
3. was für ein unix hast du? fedora core? ich weiß, dass dieses system irgendwie ab und zu da mal rumstresst..
4. psybnc wurde mit oidentd-unterstützung natürlich auch neu kompiliert und auch neu gestartet, oder?

hast du mal probiert oidentd mit den parametern -u bnc -g users (nicht die beste lösung) zu starten? hat sich bei einigen systemen als die, auf die schnelle, funktionierende lösung erwiesen..

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

t0m

Beitrag von t0m » 10. Nov 2004, 21:31

also,

um nochmal die lage zu sortieren:

zu 1.:
-rwxr--r-- 1 bnc users 530 Nov 10 20:30 oidentd.conf
zu 2.:
root 32024 0.0 0.1 2148 820 ? S Nov10 0:00 ./oidentd -u root -g root
läuft also wegen test noch immer unter root

zu 3.: Debian

zu 4.: Ja, nichtnur einmal.

Ja, das hab ich auch probiert, weil ich so den Problemen der Dateirechte und User/Gruppenzuordnungen aus dem Weg gehen wollte.

Gruß
t0m

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 10. Nov 2004, 21:37

Hi,

erste sache worüber ich gestolpert bin:

warum heißts bei dir
-rwxr--r-- 1 bnc users 530 Nov 10 20:30 oidentd.conf ?
Die datei muss .oidentd.conf heißen (mit nem Punkt davor)...


-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

t0m

Beitrag von t0m » 10. Nov 2004, 21:48

Hmm... ic hweiß ja ned warum da bei dir nen Punkt davor sein muss, aber auch das hab ich getestet...
cp oidentd.conf .oidentd.conf
Hab bnc jumpen lassen und oidentd vorher neu gestartet.

Gleicher Fehler wie vorher. Es wird immernoch der Username gespooft von dem user der den BNC gestartet hat, in meinem fall also bnc@host.de

Anmerkung:
Wenn sich die oidentd.conf im /etc/ befindet ist die Verwendung des Dateinamens korrekt.

Auszug aus der INSTALL:
when oidentd starts up, it parses the /etc/oidentd.conf
configuration file.
Gruß
t0m

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 10. Nov 2004, 22:33

jaein.

erstmal zum thema oidentd configuration files...

die /etc/oidentd.conf und die $HOME/.oidentd.conf sind zwei verschiedene Dateien. In der ersten wird gelesen welcher user überhaupt was darf und in der zweiten wird ausgelesen, wie der entsprechende user zum beispiel gespooft werden darf. Die /etc/oidentd.conf ist also eine globale richtlinie und die datei im homedir (die übrigens versteckt sein MUSS (also einen punkt vor dem dateinamen hat)) ist auf userebene wichtig.

wie ist denn der inhalt der /home/bnc/.oidentd.conf ?

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

t0m

Beitrag von t0m » 10. Nov 2004, 23:11

Es ist der gleiche wie der im Tutorial

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 11. Nov 2004, 01:11

Nun, ich glaube wir beide reden aneinander vorbei..
t0m hat geschrieben:Es ist der gleiche wie der im Tutorial
Ich habe in meinem Tutorial keinen Inhalt der $HOME/.oidentd.conf angegeben. In meinem Tutorial steht nur ein listing einer /etc/oidentd.conf . Ich sags nochmal: Das sind zwei verschiedene Dateien mit zwei verschiedenen Aufgaben und zwei verschiedenen Inhalten!

Probier mal bitte den folgenden Befehl auf deiner Shell (ausgeführt als user "bnc"):

Code: Alles auswählen

echo 'global { reply "blah" }' > /home/bnc/.oidentd.conf
Danach lass den psybnc mal bitte /jump'en! Mal schauen wie's ausgeht..

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

t0m

Beitrag von t0m » 11. Nov 2004, 13:30

Hallo Hendrick,

bin heute erst dazu gekommen das zu testen und nun bin ich glaub ich völlig verblödet.
echo 'global { reply "blah" }' > /home/bnc/.oidentd.conf
Der Befehlt trägt doch ein global reply "blah". Sprich der Ident üsste überall blah sein, oder?

Ist er bei mir nicht... es passt bei mir plötzlich. Plötzlich stimmen alle idents... Naja egal. Never change a runnig system :)

Thx 4 help @ Hendrick


Gruß
t0m

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 11. Nov 2004, 16:11

Alright.. Wenn du mich jetzt noch Hendrik nennst, ohne das c vor dem k, dann ist die Welt auch für mich in Ordnung ;-)

Viel Spaß mitm bouncer
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

SkeeTer
Newbie
Beiträge: 17
Registriert: 18. Nov 2004, 14:32
Kontaktdaten:

Beitrag von SkeeTer » 18. Nov 2004, 15:02

t0m hat geschrieben:
cp oidentd.conf .oidentd.conf
Hab bnc jumpen lassen und oidentd vorher neu gestartet.
jumpen alleine reicht aber nicht aus. Du musst den BNC Prozess komplett neu starten.

Erst dann wird der oident mit dem BNC laufen.

Deshalb ging es vermutlich auch später bei dir auf misteriöse weise, da Du irgendwann mal den rechner neu gestaretet hast oder den BNC.

So denke ich wird sich das zugetragen haben :)

Gast

problem leider auch

Beitrag von Gast » 19. Jul 2005, 16:09

Hallo,

also:
-ja- Ist in den psyBNC oidentd-Unterstüzung eincompiliert?
-ja- Ist dein oidentd gestartet? (mit user des psybnc)
-ja- Hast du die config-Datein von oidentd (besonders die /etc/oidentd.conf) angepasst?
-ja- Habt ihr den Unterschied zwischen /etc/oidentd.conf und ~bouner/.oidentd.conf herausgelesen? (Zwei verschiedene Dateien, eine müsst ihr erstellen, um die andere kümmert sich der psybnc von alleine)
-ja- Wurde der oidentd nach ändern der /etc/oidentd.conf neugestartet?

aber die .oidentd.conf die der psybnc selbst erstellen soll(te) existiert bei mir nicht. auch nicht nach restart des bnc's / oidentd demons. hoffe es kann mir jemand weiterhelfen :-) die oidentd.conf hat natürlich auch:

Code: Alles auswählen

user web3 {
        default {
                allow spoof
                allow spoof_all
                allow random
                allow hide
        }
}
danke & lg
tobi

mc5000

Beitrag von mc5000 » 24. Jul 2005, 03:32

Hallo, ich hab ein problem mit deinem Tut.
Damals war alles drin gepostet, was nötig war, aber jetzt fehlt die hälfte.Bis zum einrichten der /etc/oidentd.conf bin ich ja gekommen, aber die datei für den bnc kann ich nu nicht erstellen und ich glaub dazwischen war auch noch was, kann mich aber nicht mehr daran errinnern, was dort war.

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 29. Jul 2005, 00:26

scheisse.... ich kümmer mich drum, der fehler liegt bei mir... ich ergänz das fehlende in den nächsten tagen.. bin grad bißchen im stress, komme grade aus dem urlaub..

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

Pryde

Beitrag von Pryde » 17. Aug 2005, 15:11

Hi

Wurde das Tut schon aktualisiert?

Weil ich hab das Problem das ich oident installiert hab und die /etc/oident.conf so wie tut angepasst hab und dann hab ich die beiden Befehle ausgeführt:

Code: Alles auswählen

oidentd -u nobody -g nogroup

$> touch /home/bouncer/.oidentd.conf
$> chown bouncer:nogroup /home/bouncer/.oidentd.conf
$> chmod 740 /home/bouncer/.oidentd.con
Dann habe ich sogar den bouncer neu installiert und bei Compiling Options Identd Support Aktiviert.

Aber es funktioniert trotzdem nicht der heisst immernoch bouncer@ip

und die Datei .identd.conf hab ich auch nirgends!!

Bitte um Hilfe!

Antworten