unknown message from server (ERROR :Link denied (No matching

Wer Probleme mit seinen IRC-Services (NickServ, ChanServ, ..., NeoStats) hat, könnte hier Hilfe finden. Anope, Epona, Auspices, Airwave, cygnus, etc...
Antworten
sbomber
Newbie
Beiträge: 30
Registriert: 18. Aug 2005, 16:10

unknown message from server (ERROR :Link denied (No matching

Beitrag von sbomber » 11. Sep 2005, 23:17

Sep 11 22:35:54 2005] IRC Services 5.0.54 starting up
[Sep 11 22:35:54 2005] unknown message from server (ERROR :Link denied (No matching link configuration) [@67.159.7.252.48361])
[Sep 11 22:35:54 2005] unknown message from server (ERROR :Closing Link: [67.159.7.252] (Link denied (No matching link configuration)))
[Sep 11 22:35:54 2005] Read error from server: Connection reset by peer


das wunderliche ich finde nirgens die zahl 48361

er läst sichj starten, ist aber sofort wieder weg mit der meldung in der log siehe oben

Initialization successful, starting IRC Services.


suche nun schon 8 stunden und finde den fehler nicht bitte um hilfe welche datei ich mir noch anschauen könnte

unreal selbst läuft ohne probleme
v3.2.3
using TRE 0.7.2 (GPL)
using OpenSSL 0.9.7a Feb 19 2003
using zlib 1.1.4

* Loading IRCd configuration ..
* Configuration loaded without any problems ..
* Loading tunefile..
* Initializing SSL.
* Dynamic configuration initialized .. booting IRCd.


gruß
bomber

Benutzeravatar
codeblack
IRC-Gott
Beiträge: 277
Registriert: 2. Jan 2004, 14:01
Wohnort: Bei Nürnberg
Kontaktdaten:

Re: unknown message from server (ERROR :Link denied (No matc

Beitrag von codeblack » 12. Sep 2005, 00:09

moin,

[Sep 11 22:35:54 2005] unknown message from server (ERROR :Link denied (No matching link configuration) [@67.159.7.252.48361])
[Sep 11 22:35:54 2005] unknown message from server (ERROR :Closing Link: [67.159.7.252] (Link denied (No matching link configuration)))
[Sep 11 22:35:54 2005] Read error from server: Connection reset by peer


überprüf mal deinen link block, das du beim port nicht ausversehen einen . staht : hin hast, desweitern diesesn "unknown message from server" läst mich vermuten das du viellleicht bei der service config den falschen ircd server angegeben hast, oder die service nicht zu den server kompitabel sind, welche services nutzt du?
gruss marc
Das Leben ist ein .deb packet, nur wo ist dpkg ;-)

sbomber
Newbie
Beiträge: 30
Registriert: 18. Aug 2005, 16:10

Beitrag von sbomber » 12. Sep 2005, 00:34

ircservices-5.0.54
und
Unreal3.2

link block, das du beim port nicht ausversehen einen . staht <--- versteh ich nicht ganz

ist das erstemal das ich irc installiere


aso in der conf hab ich angegeben unreal als server
muß ich da vielleich angeben Unreal3.2 ??

gruß

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 12. Sep 2005, 04:23

Hi,
link block, das du beim port nicht ausversehen einen . staht <--- versteh ich nicht ganz
Ich versteh was du meinst, du bist über das "@67.159.7.252.48361" gestolpert. Aber ich kann dir versichern, dass das Okay ist. Das ist irgendwie der Port, der dann bidirektional benutzt wird. Das können wir erstmal außer Acht lassen.

sbomber: Irgendwie stimmen deine Konfigurationen nicht überein. Deshalb verweigert der unrealircd die Verbindung. Du machst mal bitte folgendes, damit wir hier rauskriegen, wo der Fehler liegt:

1. Poste uns bitte erstens den link-Block aus deiner unrealircd.conf, in dem du deinen Services-Server linkst.
2. Wechsle in dein ircservices-Verzeichnis, dorthin wo sich die .conf-Datei dieser Services befindet, ich glaub die heißt ircservices.conf, richtig? Dann poste uns bitte die Ergebnisse der folgenden Befehle hier ins Forum:

egrep 'RemoteServer' ircservices.conf
egrep 'ServerName' ircservices.conf


Diese Drei sachen, die wir dann gegeneinander analysieren können, sollten uns auf den richtigen Weg führen..

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

sbomber
Newbie
Beiträge: 30
Registriert: 18. Aug 2005, 16:10

Beitrag von sbomber » 12. Sep 2005, 12:23

RemoteServer 67.159.7.252 65535 "sandra03101966"


ServerName "services.no-log-irc.no-ip.org"





---------------------------------
unreal.conf
da ich net genau weis was du meinst poste ich sie komplett ^^

##############################################
# No-Log-IRC.org IRCD Konfiguration by Andre #
##############################################


loadmodule "src/modules/commands.so";


// Jetzt gehen wir paar Zeilen runter und editieren die ME:Block
me {
name "no-log-irc.no-ip.org";
info "no-logs IRC Network";
numeric 1;
};

// Im Admin Block stehen z.B. deine Opers
admin {
"sbomber";
"sbomber@gmx.de";
};

// class Blöcke definieren Verbindungs Klassen|-
class clients
{
pingfreq 90;
maxclients 500;
sendq 100000;
recvq 4000;
};

class servers
{
pingfreq 90;
maxclients 10;
sendq 1000000;
connfreq 100;
};






// mein




oper sbomber {
class clients;
from {
userhost *@*;
};
password "sandra03101966";
flags {
netadmin;
can_gkline;
can_gzline;
can_zline;
can_restart;
can_die;
global;
};
swhois "Beispiel einer whois Maske";
snomask frebWqFv;
};













link services.no-log-irc.no-ip.org {
username *;
hostname no-log-irc.no-ip.org;
bind-ip *;
port 65535;
password-connect "sandra03101966";
password-receive "sandra03101966";
class servers;

};
ulines {
services.no-log-irc.no-ip.org;
};

//Und vergesst nicht den listen block zu vervollständigen!
//Der ist nötig um den IRCd auf den Port 6665 lauffähig zu machen
//damit wir linken können!

listen no-log-irc.no-ip.org:65535 {
options {
serversonly;
};
};








// In Allow Blöck wird angegeben, wer zum Server connecten darf.
allow {
ip *;
hostname *;
class clients;
maxperip 100;
};

// Jetzt kommt der Oper Block
oper Max {
class clients;
from {
userhost *@*;
};
password "maxmustermann02";
flags
{
global;
services-admin;
can_rehash;
can_die;
can_restart;
helpop;
can_wallops;
can_globops;
can_localroute;
can_globalroute;
can_localkill;
can_globalkill;
can_kline;
can_gzline;
can_gkline;
can_unkline;
can_localnotice;
can_globalnotice;
netadmin;
can_zline;
get_umodew;
get_host;
can_override;
};
maxlogins "1";
};




// Der Listen Block, auf welchen Port der IRCd laufen soll
// Wobei 127.0.0.1 mit deiner IP ersetzt werden muss
listen 67.159.7.252:65535;

// Dieser Eintrag ist nötig für die SSL Connection
listen 67.159.7.252:6601
{
options
{
ssl;
clientsonly;
};
};


// Falls du Services am Laufen hast musst du Services hier eintragen
ulines {
service.no-log-irc.no-ip.org;
stats.no-log-irc.no-ip.org;
};

// Füge die Zeile ein, falls du Anope Services hast
include "aliases/anope.conf";
// Füge die Zeile ein, falls du ircservices Services hast
include "aliases/ircservices.conf";

// Deine Motd, später müssen wir die Dateien erstellen
tld {
mask *@*;
motd "motd.conf";
rules "rules.conf";
};

// Hier werden die PW's eingestellt zum restarten und beenden
drpass { restart "restartpwd"; die "beendetdenserverpwd";};


// Mit dem Ban Nick Block können bestimmte Nicknamen
// auf dem Server gesperrt werden.
ban nick {
mask "*C*h*a*n*S*e*r*v*";
reason "Gesperrt";
};


//Mit dem "deny channel Block" kann man Usern das
//joinen bestimmter Channels verbieten.
deny channel {
channel "*Warez*";
reason "Dieser Channel ist verboten";
};



// Nun kommen wir zu Netzwerkeinstellung
set {
network-name "No-Log-IRC";
default-server "no-log-irc.no-ip.org";
services-server "services.no-log-irc.no-ip.org";
stats-server "stats.no-log-irc.no-ip.org";
help-channel "#lobby";
hiddenhost-prefix "sbomber";
cloak-keys {
// Die 3 Keys müssen dürfen nicht identisch sein
// Bei einem Server Link müssen die gleich sein
// mit dem anderen Server
"aoAr1HnR6gl3sJ7hVUgHrEw4YwpW";
"aoArKlsWC456sJ7hVz4Zb7x4YwpW";
"jKE365SR6gl3sJ7hVz4Zb7x4YnpX";
};
hosts {
local "locop.no-log-irc.no-ip.org";
global "ircop.no-log-irc.no-ip.org";
coadmin "coadmin.no-log-irc.no-ip.org";
admin "admin.no-log-irc.no-ip.org";
servicesadmin "csops.no-log-irc.no-ip.org";
netadmin "netadmin.no-log-irc.no-ip.org";
host-on-oper-up "no";
};
};



set {
allowed-nickchars {
latin1;
};
kline-address "kline@no-log-irc.no-ip.org";
modes-on-connect "+xwG";
modes-on-oper "+xwgs";
restrict-usermodes "G";
restrict-channelmodes "G";
modes-on-join "+ntG";
oper-auto-join "#admin";
dns {
nameserver 127.0.0.1;
timeout 2s;
retries 2;
};
options {
hide-ulines;
show-connect-info;
show-opermotd;
allow-part-if-shunned;
flat-map;
fail-oper-warn;
};
maxchannelsperuser 30;
anti-spam-quit-message-time 10s;
static-quit "Client hat die Verbindung getrennt";
oper-only-stats "*";
throttle {
connections 3;
period 60s;
};
anti-flood {
nick-flood 3:60;
};
spamfilter {
ban-time 1d;
ban-reason "Spam/Advertising";
virus-help-channel "#hilfe";
};
default-bantime "0";

};

// Nun bindet wir noch ein paar brauchbare Module bzw. confen ein
include "help.conf";include "badwords.channel.conf";include "badwords.message.conf";include "badwords.quit.conf";include "spamfilter.conf";loadmodule
"src/modules/commands.so";loadmodule "src/modules/cloak.so";
//LoadModule misc/hostserv

// Mit dem Log Block kann man verschiedene Logfiles
// zu den unterschiedlichsten Zwecken erstellen lassen.
log ircd.log {
maxsize 5MB;
flags {
errors;
kills;
sadmin-commands;
chg-commands;
oper-override;
spamfilter;
kline;
tkl;
};
};

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 12. Sep 2005, 16:30

Hi,

allein aus PerformanceGründen würde ich dafür plädieren, dass du deine Services lokal auf localhost verbindest. In etwa so:

Suche in der ircservices.conf nach RemoteServer 67.159.7.252 65535 "sandra03101966", ersetze dort das "67.159.7.252" durch "127.0.0.1".

In der unrealircd.conf suchst du bitte folgendes:

Code: Alles auswählen

link services.no-log-irc.no-ip.org {
username *;
hostname no-log-irc.no-ip.org;
bind-ip *;
port 65535;
password-connect "sandra03101966";
password-receive "sandra03101966";
class servers;

}; 
daraus machst du folgendes:

Code: Alles auswählen

link services.no-log-irc.no-ip.org {
username *;
hostname 127.0.0.1;
bind-ip *;
port 65535;
password-connect "sandra03101966";
password-receive "sandra03101966";
class servers;
}; 
Danach suchst du, etwas weiter unten nach:

Code: Alles auswählen

listen no-log-irc.no-ip.org:65535 {
options {
serversonly;
};
}; 
Und veränderst es zu:

Code: Alles auswählen

listen 127.0.0.1:65535 {
options {
serversonly;
};
}; 
Noch weiter unten findest du:

Code: Alles auswählen

// Der Listen Block, auf welchen Port der IRCd laufen soll
// Wobei 127.0.0.1 mit deiner IP ersetzt werden muss
listen 67.159.7.252:65535; 
Diese drei Zeilen kannst du alle drei löschen.

Außerdem hast du ein zweites mal die ulines unten eingetragen, das ist nicht okay. Lösche bitte die folgenden Zeilen aus deiner unrealircd.conf:

Code: Alles auswählen

// Falls du Services am Laufen hast musst du Services hier eintragen
ulines {
service.no-log-irc.no-ip.org;
stats.no-log-irc.no-ip.org;
}; 
Abspeichern und den unrealircd neu STARTEN, nicht nur rehashen. Danach musst du die services starten und anfangen zu beten.

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

sbomber
Newbie
Beiträge: 30
Registriert: 18. Aug 2005, 16:10

Beitrag von sbomber » 12. Sep 2005, 18:41

super, nun laufen beide.... :shock:

aber nun ist das problem das man nicht mehr auf den irc server connecten kann

kann keine Verbindung aufbauen zu no-log-irc.no-ip.org port 65535.
und das ging vorher, also denke ich mir das nur ganz kleiner fehler wir nun gemacht haben bei der änderung

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 12. Sep 2005, 20:07

Hi,

hm, was willst du mit port 65535? Wir haben durch den Befehl ...

Code: Alles auswählen

listen 127.0.0.1:65535 {
options {
serversonly;
};
};
... dem unrealircd mitgeteilt, dass der Services-Server über den Port 65535 verbindet werden soll. Der Anschluss 65535 wird nur zum Connecten der Services gebraucht. Und es klappt doch jetzt auch, wie du selbst sagst.

Versteh ich dich richtig, dass du selbst mit deinem mIRC (oder was auch immer..) über den Port 65535 auf deinen Server connecten willst? Das ist relativ großer Blödsinn, denn der IRC-Standardport ist 6667 (und einige Ports davor und dahinter). Nur von dort solltest du deine Clients zulassen!

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

sbomber
Newbie
Beiträge: 30
Registriert: 18. Aug 2005, 16:10

Beitrag von sbomber » 12. Sep 2005, 20:37

re:

ja klar ist mir das mit dem standart port aber ich hatte ihn auf 65535 festgelegt und bin so auch rein gekommen.

aber kein problem muß ich nun wohl suchen wo ich den damals auf 65535 gesetzt habe

den der standart iss auf keinen fall mehr aktiv

kann keine Verbindung aufbauen zu no-log-irc.no-ip.org port 6667



gruß





ps: über meinen ssl komme ich rein
|20:43:54| <-psyBNC> Mon Sep 12 20:43:43 :Nutzer sbomber () versucht no-log-irc.no-ip.org port 6601 ().
|20:43:55| <-psyBNC> Mon Sep 12 20:43:43 :Nutzer sbomber () verbunden zu S=no-log-irc.no-ip.org:6601 ()

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 12. Sep 2005, 22:09

Hi,

ich kann dir sagen warum das nicht mehr geht.
Noch weiter unten findest du:
Code:

Code: Alles auswählen

// Der Listen Block, auf welchen Port der IRCd laufen soll
// Wobei 127.0.0.1 mit deiner IP ersetzt werden muss
listen 67.159.7.252:65535;
Diese drei Zeilen kannst du alle drei löschen.
Dadurch kannst du nicht mehr auf den Server verbinden. Hintergrund der Löschung war, dass du diesen zweimal geöffnet hast, einmal explizit für Serververbindungen und einmal für alle quasi. Deshalb hab ich das löschen lassen, denn es machte keinen Sinn und war relativ schlecht geconft. Wenn du jetzt unbedingt über einen nichtstandard-Port auf deinen IRC-Server rauf willst, dann empfehl ich dir, dass du folgende Zeilen nochmal in deine unrealircd.conf einfügst:

Code: Alles auswählen

listen 67.159.7.252:65534 {
	options {
		clientsonly;
	};
};
Schau, jetzt haben wir einen Port niedriger, nämlich 65534, dafür geöffnet, dass nur Clients darauf verbinden können. So sollte es sein!

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

sbomber
Newbie
Beiträge: 30
Registriert: 18. Aug 2005, 16:10

Beitrag von sbomber » 12. Sep 2005, 23:54

und wiedermal hast du mir geholfen ^^

klasse arbeit geht wunderbar


aber ich glaub ich hab mir nee scheiss service ausgesucht

ich denke anope wäre besser gewesen

weil bei der service hab ich keinen botserv

sbomber
Newbie
Beiträge: 30
Registriert: 18. Aug 2005, 16:10

Beitrag von sbomber » 13. Sep 2005, 18:25

noch zwei fragen,
  • 1. gibt es zu ircservices-5.0.54 ein modul botserv ?
    2. wo kann ich eigendlich ein pass wort setzen, damit man auf den irc nur noch per passwort kommt ?

gruß stefan

Hendrik
Chef
Beiträge: 2076
Registriert: 2. Sep 2003, 16:43
Wohnort: Berlin
Kontaktdaten:

Beitrag von Hendrik » 13. Sep 2005, 23:47

Hi,

1. ich hab mal etwas gegooglet und musste feststellen, dass es für die ircservices keine botserv-module gibt. Es gibt laut mailingliste einige bestrebungen sowas zu bauen, aber bisher hat das wohl niemand fertiggestellt. die kern-entwicklergruppe stellt sich auch eher gegen so ein vorhaben, da botserv wohl im programmdesign nicht wirklich vorgesehen war und ein nachträgliches einbauen schwierig wäre..

2. passwort einstellen funktioniert wie folgt im allow-block:
Du suchst in deiner config:

Code: Alles auswählen

// In Allow Blöck wird angegeben, wer zum Server connecten darf.
allow {
ip *;
hostname *;
class clients;
maxperip 100;
};
Und fügst in diesen Block ein password <connection-password>; ein. Weiteres erzählt dir die Offizielle UnrealIRCd Dokumentation

-Hendrik-
Einmal lesen, für immer glücklich: Hinweise zum Forum
--
Programming is similar to sex. If you make a mistake, you have to support it for the rest of your life.

sbomber
Newbie
Beiträge: 30
Registriert: 18. Aug 2005, 16:10

Beitrag von sbomber » 14. Sep 2005, 18:28

re:

thx hat wunderbar geklappt :mrgreen:

jo ich sagte schon anope wäre wohl besser gewesen weil da gibt es nee ganze lade module

hab es auch kurz probiert aber net geklappt ^^ werd es irgend nochmals versuche drauf zu bekommen

gruß

Antworten